Victory Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
I have noticed that my fuel mileage has seemed to be going down lately. Today we took the bike out for the 2nd time this year and smelled gas on start up and slow speeds. There was no gas smell when I went into the shop to get it out. We road about 20 miles to eat and I didn't smell any gas when we parked. We were at the restaurant about 45 minutes and when we got going through the city streets I told my wife that i smelled gas. She said she did too. I stopped, checked the gas cap to see if it was lose or I was even thinking I might have left it somewhere when I filled up. I did not stop to get gas on this little trip to town, so It wasn't spilled gas from a fill up. But we only smelled it at slow speeds. We are headed to the Smoky's in two weeks and I need to get this issue resolved. Hoping for some help on here and hoping for an easy fix. If not I will call the dealer and take there. Any help would be appreciated.
 

·
Registered
Joined
·
682 Posts
I'm not sure if the vision has a vent tube or not, but if it does try taking a look at it and make sure it's not kinked or crushed anywhere
 

·
Registered
Joined
·
2,348 Posts
I have noticed that my fuel mileage has seemed to be going down lately. Today we took the bike out for the 2nd time this year and smelled gas on start up and slow speeds. There was no gas smell when I went into the shop to get it out. We road about 20 miles to eat and I didn't smell any gas when we parked. We were at the restaurant about 45 minutes and when we got going through the city streets I told my wife that i smelled gas. She said she did too. I stopped, checked the gas cap to see if it was lose or I was even thinking I might have left it somewhere when I filled up. I did not stop to get gas on this little trip to town, so It wasn't spilled gas from a fill up. But we only smelled it at slow speeds. We are headed to the Smoky's in two weeks and I need to get this issue resolved. Hoping for some help on here and hoping for an easy fix. If not I will call the dealer and take there. Any help would be appreciated.
My wifes 14 XR always smelled of gas from just after it was new.
Real faint. Then it got stronger. The fuel rail was leaking.

Here is a picture of the assembly:
http://www.ebay.com/itm/Polaris-Victory-Cross-Country-Fuel-Injectors-/380587243734?hash=item589cc478d6&vxp=mtr

The rail is 3 metal pieces, one in the middle that plugs into the fuel fitting on the hose from the fuel tank and 1 that bolts on to each head that the injectors seat into. These 3 sections are connected by two hoses which seem to be just glued on to them, could be vulcanized.

When the smell got worse I pulled the cheese wedge on the right side, the timing cover side. The center section of the rail, where it was bonded to the hose which connects to the rear injector section of the rail was dripping gas onto the motor. 1 drip about ever 10 -15 seconds. It had come unbonded and started to leak.

Might want to take a look. You could have a leak like we did.
 

·
Registered
Joined
·
222 Posts
I had a similar issue. I smelled gas when it had been parked for a few hours or overnight, but it ran fine. Very gradually the smell increased and one day in the garage, my wife spotted what looked like a few drops of water. It was gas. The old fuel line had started to crack and split just under the hose clamp at the bottom of the tank. A quick trip to Autozone and $4 later a new fuel line stopped the leak and the gas smell.
 

·
Registered
Joined
·
1,638 Posts
2004 Vegas needed TB cleaning. I finally got around to it. Took tank off, cleaned it up. Put it back together. Hit starter and before it cranked I noticed gas leaking. I thought I did not tighten clamps tight enough. Took the tank off. Checked and tightened. Put the tank on, cranked and everything looked good. Rode a couple of blocked and it smelled gas and noticed it leaking like crazy. Fuel line was definitely the culprit but this was all a major pain in the butt!

All I can say it that if you guys get a strong gas smell, don't mess around, go ahead and change out the fuel line.
 

·
Moderator
Joined
·
13,188 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #7
Thanks for all the help. And for what it is worth. My Kaspersky virus protection has blocked the Trojan Virus on this forum three times today. Everyone should check out the computer really good and see if they have been compromised. Someone on here has a virus.
 

·
Super Moderator
Joined
·
6,375 Posts

·
Premium Member
Joined
·
1,181 Posts
Thanks for all the help. And for what it is worth. My Kaspersky virus protection has blocked the Trojan Virus on this forum three times today. Everyone should check out the computer really good and see if they have been compromised. Someone on here has a virus.
Seamonkey browser and AD blocker period...... that will help you out..
 
1 - 9 of 9 Posts
Top