Victory Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
Not sure what's causing this but today I drove the bike o work and at my first red light a guy I work with was next to me and he commented when we got to work I was burning oil. I did notice this morn and my ride home that at low idle I.e. stop signs or lugging slowly behind traffic I can smell what I describe as a running rich motor. After I got to work and had the conversation I was thinking maybe I left the choke on but when I left it was not. On my ride home I def have a rich smelling motor at low idle any thoughts don't remember this last year and I just got it back from service from the dealer?


Sent from my iPad using MO Free
 

·
Registered
Joined
·
813 Posts
I just got it back from service from the dealer?
So what did you have it serviced for? What did they do? I would be thinking you have a dirty throttle body..
 

·
Registered
Joined
·
58 Posts
Discussion Starter #4
So what did you have it serviced for? What did they do? I would be thinking you have a dirty throttle body..
I am asking my self the same thing basically they changed the oil, tires, put insp. sticker on and out the door. One thing that I did think of today is I treated it with stable when I stored it. Gonna get a tank or 2 through and go from there. Have you ever cleaned your own throttle body?


Sent from my iPad using MO Free
 

·
Registered
Joined
·
813 Posts
Yep right after I bought the bike. I do almost all of my work. It's not that bad.


Sent from Motorcycle.com Free App
 
1 - 5 of 5 Posts
Top