Victory Motorcycle Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hi all. I have a 2013 Hammer with lloydz torque tubes, maximus tuner that was remote tuned by 801 and has Bassani 2-1. Bike has 13500 km and original everything else mechanical battery plugs etc.

Now the issue. The annoying squeak that appears once in a while seems to be coming from front of bike maybe headlight bucket area or fuel tank possibly?. Not very loud almost blends in with motor sounds almost like a squeaky bed spring or fan belt though nowhere near as loud. Seems to come and go I've only noticed it riding slow like 2nd or 3rd gear speeds.

Related possibly to this is a few times my rpm dropped to 750-800 briefly when stopping at a light. Normally after my tune All warmed up it idled at 850-900 bouncing back and forth.

Other than that bike runs great and the rpm drop has only happened a few times on very hot days. Today was cooler nothing out of the normal at first bike ran like a beast. Even thought the squeak fixed itself till I slowed down near home and there it was again. When I pulled into garage and let it idle on stand squeak disappeared. I did think it sounded louder when I put my head down near gas cap which might mean fuel pump whining?

Thinking of starting by switching out plugs and checking battery since it's now going on 6. It's always been tendered and fires right up instantly so not sure...any help is appreciated. Thank you!

Sent from my SM-G920W8 using Tapatalk
 

·
Premium Member
Joined
·
13,709 Posts
I agree; it's time for a new battery. Some people like to see how long they can get one to last but I don't like to be on the side of the road for procrastinating like that.

The squeak could be anything. Can't help with that one.

Change in rpm could be a vacuum leak like maybe a tiny crack in the throttle body boot starting but not really a problem yet. Could be a vacuum line. If it was a pre-08 bike I'd say clean the throttle body but it isn't so.... Could be the fuel pump not getting the power it needs due to a weak/failing battery.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
I'll start with checking the battery. I'm just really hoping it's not the fuel pump. I've read of alot of failures and even a recall but apparently dealer says mine isn't part of it.

Thanks!

Sent from my SM-G920W8 using Tapatalk
 
1 - 3 of 3 Posts
Top