Victory Motorcycle Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I recently purchased a black license plate bracket with light for my 2013 victory highball through arlen ness. My dealer installed it on my bike before I picked it up last week, when I got the bike home I noticed that when my bike is running or key is on, that I have no rear tail-light. my new license plate bracket light is on, and my brake light will illuminate if I apply the brakes, but no tail light. I looked at the wiring , nothing looks wrong, all my fuses look fine as well, can you please give me some guidance on this situation . my dealer is 250 mi away

Thanks in Advance

2013 High Ball
 

·
Administrator
Joined
·
5,988 Posts
I recently purchased a black license plate bracket with light for my 2013 victory highball through arlen ness. My dealer installed it on my bike before I picked it up last week, when I got the bike home I noticed that when my bike is running or key is on, that I have no rear tail-light. my new license plate bracket light is on, and my brake light will illuminate if I apply the brakes, but no tail light. I looked at the wiring , nothing looks wrong, all my fuses look fine as well, can you please give me some guidance on this situation . my dealer is 250 mi away

Thanks in Advance

2013 High Ball
Do you have a voltmeter?

Most likely the license plate was tapped on the tail light wire, and one of the wires is not making good contact. A voltmeter will help you identify the trouble spot quickest.
 
1 - 2 of 2 Posts
Top