Victory Motorcycle Forum banner
41 - 60 of 60 Posts

· Registered
Joined
·
723 Posts
Discussion Starter · #42 ·
Sounds like you got my kinda luck. Yea I would double check connections and all that...but also make sure those little rubber nipple things are on the the throttle body and it aint sucking air.
Yeah that's what I'm gonna do, double check everything. Make sure there's nothing out of place. I recapped the nipples on the tb not too long ago, the old rubber caps were gone :crzy:
 

· Registered
Joined
·
723 Posts
Discussion Starter · #43 ·
If i'm not mistaken that airbox/filter is off of a 99 v92c. My mechanic told me that to get the best bang for my buck, to get one of these setups to replace my box with the tubes. Says it breathes better. Obviously a big sucker with a power commander is better....
I looked up both intakes, they look very similar. I wish I could meet whoever owned the bike before me. I have many questions for him:confused:
 

· Registered
Joined
·
723 Posts
Discussion Starter · #45 ·
Well I put the old sensor back on and it fired right up and idled fine. Didn't have time to ride it, but it seems to be back to normal
 

· Registered
Joined
·
723 Posts
Discussion Starter · #47 ·
I guess just defective. I checked the part before I ordered it and it is the correct replacement, and other people have used that same part as a replacement. So I guess I just got a bad one
 

· Moderator
Joined
·
13,966 Posts
You guys want to find out who owned the bike before you.
Go to your state capital license bld and ask them. It might coast you less then $10 bucks to find out
 

· Registered
Joined
·
723 Posts
Discussion Starter · #52 ·
I think it was the broken wire at the map sensor that was causing those problems. After I fixed that and put the old tps back in, the bike hasn't given me one problem (knock on wood). Hasn't stalled, pulls strong, no more rough spots. Just figured I would put that out there in case someone else has a similar problem
 

· Premium Member
Joined
·
10,393 Posts
Periodic TPS calibration is not required. If you replace the TPS it should be recalibrated. You can replace the TPS on your own & see if it cures your issues, you'll need a digital wrench (dealer) to make any adjustments. You mentioned your battery terminals are tight-what shape is the battery itself in? You can get a TPS at NAPA
part # 2-19187, Victory doesn't have a part # you have to get an entire throttle body.
NAPA hey??? Let's see if they got an outlet in Australia....
 

· Premium Member
Joined
·
10,393 Posts
I think it was the broken wire at the map sensor that was causing those problems. After I fixed that and put the old tps back in, the bike hasn't given me one problem (knock on wood). Hasn't stalled, pulls strong, no more rough spots. Just figured I would put that out there in case someone else has a similar problem
Where's the MAP sensor?
 

· Registered
Joined
·
1,701 Posts
Ghost Rider. Just pointing out this is a 9 year old post and he hasn't been seen in three years. Didn't want you waiting for an answer. The Byte guy even longer.

MAP should be under the tank between the cylinders.
 

· Premium Member
Joined
·
10,393 Posts
Ghost Rider. Just pointing out this is a 9 year old post and he hasn't been seen in three years. Didn't want you waiting for an answer. The Byte guy even longer.

MAP should be under the tank between the cylinders.
Thanks
Does it matter how old the thread? ... if it's on subject ,
(TPS replacement is the search I did ), and gets an answer?
I'll do a search for MAP sensor then see if I can get a specific location for it...
 

· Registered
Joined
·
143 Posts
Thanks
Does it matter how old the thread? ... if it's on subject ,
(TPS replacement is the search I did ), and gets an answer?
I'll do a search for MAP sensor then see if I can get a specific location for it...
It would have been in the stock airbox.
HC probably eliminated it a long time ago.
Put an S&S air box and some other stuff on a 2006 Hammer tied the connector for the MP sensor out of the way and had it dynoed. Don't remember who tipped me that it wasn't needed but it was someone on the VOG.
Seems the pre '08 didn't need it if you were using a fuel management system and better intake.
The S&S air cleaner had a hole to mount one, I just plugged it.
 
41 - 60 of 60 Posts
Top