Victory Motorcycle Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Alright so got an electrical question. When I hit either turn signal, the rear will blink once and then stop. However, the front signal wont flash at all. I have checked relays and fuses. Wondering if it's a ground issue up front causing the problem. Any advice is greatly appreciated. BTW it's an 06 8 ball. Thank you. wac
 

·
Registered
Joined
·
545 Posts
Alright so got an electrical question. When I hit either turn signal, the rear will blink once and then stop. However, the front signal wont flash at all. I have checked relays and fuses. Wondering if it's a ground issue up front causing the problem. Any advice is greatly appreciated. BTW it's an 06 8 ball. Thank you. wac
Start your troubleshooting with the bulbs themselves... don't look at them swap them out with a bulb that you have tested to be good. If that doesn't take care of the problem then step two is the fuses and relays... again swap them out with ones that you have tested to be good. To test for the ground up front just run a loose wire from the chassis to the light and see if they work properly... if so, then ground the front end back to the chassis.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
Handy, thank you for the tips. I will be looking more into the issue this weekend. I will share what it was.cheers
 

·
Premium Member
Joined
·
1,572 Posts
Alright so got an electrical question. When I hit either turn signal, the rear will blink once and then stop. However, the front signal wont flash at all. I have checked relays and fuses. Wondering if it's a ground issue up front causing the problem. Any advice is greatly appreciated. BTW it's an 06 8 ball. Thank you. wac
Check your ground...then check your harness underneath rear fender to be sure wire insulation is in tact.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
So i went ahead and pulled the rear fender off. Found a lot of taped up sections of rubbed wiring. Looks like a crappy wiring job. So i will be cutting and replacing all the wiring in the back. The front wiring all looked good and im kinda confused as to why i cant get the front signals to work. I checked all grounds. Is there some kind of module or box other than the fuses and relays for signals on these bikes?
 

·
Registered
Joined
·
50 Posts
the only other box I know of is the auto cancel module for your turn signals, but I believe even when this is blown you still have turn signals just no auto-cancel but I could be wrong
 

·
Premium Member
Joined
·
1,572 Posts
So i went ahead and pulled the rear fender off. Found a lot of taped up sections of rubbed wiring. Looks like a crappy wiring job. So i will be cutting and replacing all the wiring in the back. The front wiring all looked good and im kinda confused as to why i cant get the front signals to work. I checked all grounds. Is there some kind of module or box other than the fuses and relays for signals on these bikes?
Replied in the other thread....more then likely you fried your ACM.
 
1 - 7 of 7 Posts
Top