Victory Motorcycle Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I noticed recently that I'm getting a vavletrain tick while riding or even at idle. It sounds like a bad lifter or like when a rocker arm on a V8 is set with a little to much valve lash. It has been warmer here but not that warm. I had the oil changed 1,200 miles ago and checked to oil level to make sure that it was topped off and everything looks good there. I only have 1,700 miles on the bike and concerned that there could be a bigger issue. Also, upon strat up I get a rod knock for a few seconds and then it clears up. I know this could be attributed the fact that the oil drains to the bottom and takes a few seconds to build pressure. My question is, has anyone had this issue? If so, what was the problem? Should I switch from the Victory oil and go with a better synthetic?
 

·
Registered
Joined
·
254 Posts
Also, upon strat up I get a rod knock for a few seconds and then it clears up. I know this could be attributed the fact that the oil drains to the bottom and takes a few seconds to build pressure. My question is, has anyone had this issue? If so, what was the problem? Should I switch from the Victory oil and go with a better synthetic?
This happens to me for my first start of the day. Usually lasts about two seconds. Don't hear it the rest of the day during start up. I have 53xx miles on mine. Using Vic oil and filter. No mods.

Don't know about your first issue.
 
1 - 3 of 3 Posts
Top