Victory Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys I’ve been having issues with my 08 Vegas and can’t seem to get it going . The fuel pump doesn’t prime or when it does the bike will start up and run extremely rough, misfiring crackling and popping and fade out then back in and then just dies and won’t start back up agin. I took it to a shop and had a new fuel pump put in thinking that was the issue. It ran enough to go about 10miles but during anytime the rpms were fairly low it would cut out and shut off and getting it started back up was a roll of the dice. Things I’ve done so far have been the changing out of a new fuel pump and checking the relay switch along with changing out the ignition coil and new spark plugs. At this point I am completely at a loss. If anyone has any input or experienced anything similar I would really appreciate the help . Lastly I recently removed the tank and discovered two male ends that tie into the wiring harness that I have no idea what they are for or if they are even related to the issue I am having .
252479
252480
252481
 

·
Registered
Joined
·
4 Posts
Sounds like Fuel Injection issues from my limited mechanic knowledge. Dirty injectors or faulty ones. I am new to victory bikes but if memory serves they are fuel injected. Thay would be my next check.
 

·
Premium Member
Joined
·
14,115 Posts
Spray some starting fluid into your intake while it's running and see if there's a difference. Could be a lot of things. A speed or cam sensor, cracked throttle body boots, loose connection at the battery or ground, things like that.
 

·
Premium Member
Joined
·
2,907 Posts
You had the fuel pump replace, did they replace the fuel filter also?
 

·
Registered
Joined
·
1 Posts
Hey guys I’ve been having issues with my 08 Vegas and can’t seem to get it going . The fuel pump doesn’t prime or when it does the bike will start up and run extremely rough, misfiring crackling and popping and fade out then back in and then just dies and won’t start back up agin. I took it to a shop and had a new fuel pump put in thinking that was the issue. It ran enough to go about 10miles but during anytime the rpms were fairly low it would cut out and shut off and getting it started back up was a roll of the dice. Things I’ve done so far have been the changing out of a new fuel pump and checking the relay switch along with changing out the ignition coil and new spark plugs. At this point I am completely at a loss. If anyone has any input or experienced anything similar I would really appreciate the help . Lastly I recently removed the tank and discovered two male ends that tie into the wiring harness that I have no idea what they are for or if they are even related to the issue I am having . View attachment 252479 View attachment 252480 View attachment 252481
Hey guys I’ve been having issues with my 08 Vegas and can’t seem to get it going . The fuel pump doesn’t prime or when it does the bike will start up and run extremely rough, misfiring crackling and popping and fade out then back in and then just dies and won’t start back up agin. I took it to a shop and had a new fuel pump put in thinking that was the issue. It ran enough to go about 10miles but during anytime the rpms were fairly low it would cut out and shut off and getting it started back up was a roll of the dice. Things I’ve done so far have been the changing out of a new fuel pump and checking the relay switch along with changing out the ignition coil and new spark plugs. At this point I am completely at a loss. If anyone has any input or experienced anything similar I would really appreciate the help . Lastly I recently removed the tank and discovered two male ends that tie into the wiring harness that I have no idea what they are for or if they are even related to the issue I am having . View attachment 252479 View attachment 252480 View attachment 252481
I'm assuming that you've replaced the fuel?

Mine was doing something similar, and siphoning the fuel and putting in new solved the problem.

Although the fact that you said that it wouldn't prime sounds different. Does it prime every time you toggle the kill switch?
 
1 - 6 of 6 Posts
Top