Victory Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Here is what I have.
D&D Pipes with baffles in
Lloydz High Flow air filter
Llloydz timing wheel set at +5
unplugged the O2's

Really woke it up, but concerned on color of plugs (Grayish in color)

I believe I'm okay! Any insight for me.

Thx, Larry
 

·
Registered
Joined
·
784 Posts
Might be a bit much without a fuel controller.
 

·
Registered
Joined
·
12,296 Posts
I have pretty much the same mods, but add the Lloydz IAV and fuel controller and my plugs come out looking a bit on the sooty side. I'd rather have 'er running rich than lean. In spite of a rich mixture, I get a tad over 50 mpg at hwy. speeds from 50 to 65--that means I'm in 5th gear.
 

·
Registered
Joined
·
784 Posts
It should help, but not every time. You went from a lean runner and made several mods that can make it more so. How much or how bad it could be will have to wait for more knowledgeable folks.
It may be so hot you can't ride it in warmer weather. Are you in NY or Florida now? Either way you are in the neighborhood of 2-3 of the best Vic tuner/guru's out there. Consult them, or hang around, some hang out here.
cheers
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
I'm going to run it a while and keep ck'g the plugs. There's no popping or pinging. I may be putting a AFR Gen4 or PC5 w/ Auto tuner later. Everything I read say to start at +4 on the timing wheel, but I saw some going as high as +6 or +8. I think I choose the right setting.
 
1 - 6 of 6 Posts
Top