Victory Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
my fog lights are not on when i start the bike but they are on after i ride for a while. i got a 04 92tc
 

·
Moderator
Joined
·
13,235 Posts
Your not telling us enough
Guessing the lights are not wired right you might need a relay in there.
 

·
The Diamond
Joined
·
4,001 Posts
the lights are not automatic. There should be a switch , Since they are coming on without you doing anything there is definitely something wrong.
 

·
Registered
Joined
·
156 Posts
There is a switch for the auxilliary lights on the upper fork under the right side of the upper part of the triple clamp. I have a 05 V92-TC it could be in the same spot. put your hand under where the handlebars are attached on the right side and you'll feel the switch. I had to take it apart and futz with it to get it to work, I thought it was broken. Mike
 

·
Registered
Joined
·
8 Posts
The 2005 V92TC Fog/Driving Lights have the Switch mounted under the Upper Triple Tree on the Right Side it is also Hardwired to the Low Beam Headlight Power Circuit when You go to High Beam the Fog/Driving Lamps turn off. My first manual Switch lasted 3 months on A new Bike took it back to the Dealer they Kept the Bike 3 Weeks While waiting for parts. (the Bike Gained 75 miles on Odometer while in the Shop awaiting parts.):mad: New Switch/wiring Harness lasted the rest of Warrenty Period then went south. I have now removed the Cheap Plastic Switch (made in China) and Hardwired Lamps without switch all is well. Ps old Dealer went Belly up too many miles appearing on Equipment in Shop I guess.:ltr: New Dealer 70 miles away one way but it is a nice ride through the South Louisiana Swamp Land plenty of Gators and other Wildlife to look at. Doug. :D
 
1 - 6 of 6 Posts
Top