Victory Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
popping from my exhaust ONLY after the bike warms up? After installing Bassani Pro Street Turn Outs, S&S intake, PC-V and having the bike Dyno Tuned the vast majority of the popping is gone. What little I get is on decel and its generally only one single small pop...no big deal and not something I am worried about. Just curious why the pop is only present when the bike is warm. If I turn it on cold I can blip the throttle all I want and get ZERO popping but once the bike is warmed up and the idle RPM's drop back to normal I will start getting the pop. What would be the cause of that? 2011 Victory Vegas 8 Ball with above mods!
 

·
Registered
Joined
·
103 Posts
I just switched my exhaust to what you have,I get the pop but i thought it was the way i was riding, "not to easy on throttle" if you catch what im saying.. My next investment is the Lloydz IAV from what i read should fix all concerns, but you have the PC-V, it might be worth the $80 to try...
 

·
Premium Member
Joined
·
4,901 Posts
You should let the engine warm up before you ride off on it. The reason it doesn't pop when cold is it runs richer until it reaches operating temperature.
 

·
Premium Member
Joined
·
1,018 Posts
You should let the engine warm up before you ride off on it. The reason it doesn't pop when cold is it runs richer until it reaches operating temperature.
Totally correct here .. Just adding that once added Auto Tune stopped the popping and rarely get just a crackle now and then through gear changes that have to listen for or wouldn't hear them ...
 

·
Registered
Joined
·
220 Posts
You should let the engine warm up before you ride off on it. The reason it doesn't pop when cold is it runs richer until it reaches operating temperature.
I always let the bike warm up, I never ride a cold motor. Im looking at a similar setup, you think that IAV would fix this? I was going to get one anyways
 

·
Registered
Joined
·
43 Posts
Discussion Starter #6
I just switched my exhaust to what you have,I get the pop but i thought it was the way i was riding, "not to easy on throttle" if you catch what im saying.. My next investment is the Lloydz IAV from what i read should fix all concerns, but you have the PC-V, it might be worth the $80 to try...

If you get the IAV please post your results here if you dont mind. Would love to hear how it works out for you!
 

·
Registered
Joined
·
43 Posts
Discussion Starter #7
Also might be worth mentioning that if I am in for example 4th and down shift to 3rd without rolling back on the throttle it will go, "poppopop, pop, pop." Is that normal or a sign of a exhaust gasket leak. Would an exhaust leak have shown on my dyno run. The bike made 97Hp and 108 ftlbs of torque

 
1 - 9 of 9 Posts
Top