Victory Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I have a 2013 CCT with no power to 2 of the 3 lighter plugins. The one in the fairing and the one in the trunk are not working. The one in the left side hard lower works fine. What am I missing here? Thanks for the help.

_____________________
2013 CCT Boardwalk Blue
 

·
Registered
Joined
·
784 Posts
Right side panel just to the left of the fuse box is a free standing fuse. It is hard to spot, get out the OM if you have one or download on off the Vic site. There is another under the front cubby cover between the battery and the front jug. it is in a similar fuse holder. Looks like one wire band going in and has a water resistant cover on it. They can be hard to spot. IIRC the one on the right side is the one for the rear of the bike. There is also one of these funny looking holders in the fairing. It is findable but be sure you know what you are looking for. Vic is good at hiding fuses.

Hope this helps.
 

·
Registered
Joined
·
2,076 Posts
As LostinTX noted, it doesn't look like a fuse cover. Under the right (as you're sitting on the bike) side cover is the main fuse holder cover. NOT among those fuses, but in the same general vicinity as that big fuse cover, is a blue piece of plastic, on the end of a wire. That snaps off to reveal a fuse (20 amp, as I recall), and is the fuse for the (always-hot) dash and trunk outlets. I asked the same question last year, so that's how I know.

You need any help figuring out what caused that fuse to blow?
 
1 - 5 of 5 Posts
Top