Victory Motorcycle Forum banner

1 - 20 of 21 Posts

·
Premium Member
Joined
·
1,010 Posts
Discussion Starter #1
I'm doing my weekly engine oil check tonight and I notice a coating of oil on the rear facing cooling fin, about midship on the head. See photos. I really can't determine where the oil is coming from, but it doesn't seem to be coming from the exhaust flange.

Oil level is where it was at last week. So fellas, what the hell do I have going on here?:confused: I haven't noticed any loss of power and I've been riding every day this week. I'm reaching out to my mechanic to describe what I found.

Just shy of 9K on the XC and you can see my mods below. Thanks.
 

Attachments

·
Premium Member
Joined
·
1,010 Posts
Discussion Starter #3
sounds to me like a exhaust leakthumb up
When I first laid down on the driveway to get a better look, I thought that was where it was coming from too. I ran my finger around the exhaust and there really wasn't any residue. But, it certainly makes sense that would be the suspect location.

Do you know if these exhaust fasteners need to be torqued down? Thanks much. :)
 

·
Registered
Joined
·
634 Posts
Lloydz gaskets alledgedly prevent that. You can put a wrench on the exhaust bolts and be sure they're tight. If it is the exhaust...more popping should have been occurring. What's the diagnosis from KMC?
 

·
Premium Member
Joined
·
1,010 Posts
Discussion Starter #5
I put the Lloydz gaskets in when I had the D&D's and Cams installed. Hasn't seemed to be popping anymore than it usually does, which isn't very often.

I'll give KMC a call in the am. Thanks much. thumb up
 

·
Premium Member
Joined
·
113 Posts
It may seem weird but check the top connection on the crank case breather tube. It has a rubber connector on the throttle body.

I've seen this work it's way loose and drip oil on the front of the fins, where it's hard to see. The oil then migrates down to the lower side of the jugs where it can be readily seen.

Hope whatever is wrong, it's an easy fix!

Bill


Sent from my Motorcycle iPhone app
 

·
Premium Member
Joined
·
1,010 Posts
Discussion Starter #7
Thanks Bill, I'll check that out today. thumb up
 

·
Registered
Joined
·
97 Posts
ASM - Breather Tube -

RedRocker,
Believe Buellx72 is correct. At or around 2K miles, noticed oil on my fins. Took the tank off to get a better look. The rubber peice that is attached to the ASM - Breather tube (#8) had split in several areas. You have to purchase the whole thing unless it is under warranty. I did not want the heat and or oil fumes going back into the engine. Plugged the end at the top of the motor. Then at the bottom ran tube out the bottom of frame. Works great!!
 

Attachments

·
Premium Member
Joined
·
1,010 Posts
Discussion Starter #9
RR,

Thanks for the detailed post. I'll let you know what I discover. thumb up
 

·
Premium Member
Joined
·
1,010 Posts
Discussion Starter #11 (Edited)
So.....did you get to the bottom of this?? Resolve the issue?
Not exactly....Kyle said he'd be shocked if it were the Lloydz exhaust gaskets, so he told me to wipe down the cooling fin and see if it reappears. So we took a 180 mile ride to RI on Sat and a short ride on Sun....all clear. I commuted to work on Mon and when I got home I noticed there was a very thin film of oil on that same cooling fin. Talked to Kyle today and he said it could be the breather tube as RR had suggested.

I'm going to Kyle's shop on Friday afternoon so he can look it over. I think I'm out of warranty, but I don't trust anyone else to work on my XC anyway. Plus, I need to go over some winter project ideas with Kyle. :D
 

·
Premium Member
Joined
·
1,010 Posts
Discussion Starter #12
Just got back from KMC Power Sports....Kyle was busy Dyno-Tuning some bikes so Alex looked over the XC. It wasn't the breather tube, that was fine, so he cleaned up around the fin and let the motor idle for just a bit. No trace of any oil. Before I left the house, the amount of oil on the fin hadn't increased, so I really wasn't sweating it. Kyle and Alex said its residual oil working it's way out from when they installed the Lloydz cams a while back. Sometimes during a Cam install, oil finds it's way around the sleeve and now it's just finding it's way out.

Got to meet Shooter at Kyle's while he was getting a new rear tire installed (Metzler) on his Ness XC. Great to meet you, man! thumb up

32 miles back to the house and everything looks great!
 

·
Registered
Joined
·
53 Posts
Hey Blueline, it was nice meeting you today at KMC. Hope everything went well for you on the Dyno. I gotta tell you I had a great ride back to NH . I noticed a huge difference in power with my CC. Take care...
 

·
Premium Member
Joined
·
1,010 Posts
Discussion Starter #15
Glad that worked out for you. Peace of mind. Missed you again..it was my bike on the dyno. Stay safe.
Oh hell...if I would have known that, I would have took a ride over there. How did your Dyno numbers look this time around?
 

·
Premium Member
Joined
·
1,010 Posts
Discussion Starter #16
Hey Blueline, it was nice meeting you today at KMC. Hope everything went well for you on the Dyno. I gotta tell you I had a great ride back to NH . I noticed a huge difference in power with my CC. Take care...
What new goodies did you have Kyle install on your XCT? No doubt about the ride back to NH...todays weather was wicked nice. :D
 

·
Registered
Joined
·
634 Posts
NH4ME. You came to the right place...."where the power lives". Made that beautiful bike even better. Have fun and ride safe.
 

·
Registered
Joined
·
634 Posts
Oh hell...if I would have known that, I would have took a ride over there. How did your Dyno numbers look this time around?
Yeah..you should have come to the dyno. Couldn't get back to the shop....had to beat the traffic home.
Without the 'Flectors and a decent day....made 116.24HP and 114.10 torque. Bike performs super good. Kyle also installed the 1/4 turn throttle. Today was a good, good day.

Look forward to catchin' up with you. Ride safe.
 

·
Registered
Joined
·
53 Posts
What new goodies did you have Kyle install on your XCT? No doubt about the ride back to NH...todays weather was wicked nice. :D
Hey RedRocker, Kyle installed cams, lloydz new air filter, lloydz adjustable timing piece and lloydz idle air valve. I ended up with 114.47HP\113.85TQ. I am happy with the results and its like riding a new bike all over again. cheers
 

·
Premium Member
Joined
·
1,010 Posts
Discussion Starter #20
Yeah..you should have come to the dyno. Couldn't get back to the shop....had to beat the traffic home.
Without the 'Flectors and a decent day....made 116.24HP and 114.10 torque. Bike performs super good. Kyle also installed the 1/4 turn throttle. Today was a good, good day.

Look forward to catchin' up with you. Ride safe.
Very nice numbers! thumb up I know you have a long way to go to get back home. How do you like the 1/4 turn throttle?
 
1 - 20 of 21 Posts
Top